It is currently Thu Jul 27, 2017 7:36 pm

All times are UTC [ DST ]




 Page 1 of 1 [ 8 posts ] 
Author Message
 Post subject: Random mumble and grumble
PostPosted: Sat Apr 01, 2017 10:21 am 
User avatar

Joined: Sun Dec 19, 2010 3:46 am
Posts: 1387
Location: Malmo, Skane (the country)
Latest update brought with it a nice feature for me.
Now it doesn't save settings anymore, so every time I start the game all the settings are back to default. That means I have to redo all the graphic settings, key bindings, sound ... Really boring after a while since the game tend to crash quite often for me.
It can't even find plugins and skins anymore.

Figured it had to do with security settings on the Lotro folder in documents. Tested around with that, ran the game as admin. Tried to remove the folder start game, quit, move files back and start again. Nothing helps.

Found one thing that might be the cause. When I quit the game it used to take bit of time, now it's instant. That led me to that the game isn't quitting correctly and as settings are saved on exit nothing is saved. Same happened if I got a crash earlier and had changed something with sound settings or similar. Had to redo the changes at next startup.

So, now I have nuked everything and start from scratch in hopes that will help.

This game has brought me more problems than any other application or system I've ever come across, with a possibly exception for Windows ME edition.



_________________
Image
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Sat Apr 01, 2017 3:49 pm 
User avatar

Joined: Thu Nov 24, 2011 2:59 pm
Posts: 1092
Location: Sweden
Silly question maybe, but shouldn't this be available to check in some log file somewhere? The reading/writing of user settings, I mean.
I'm sure I've read somewhere a while back of there being log files available for tracing things like these, but I can't remember where they are.
I tried having a look for them now, but I could only find various logs for launcher/logging in and for patching and such, so they might be in some other place.

Maybe searching around the forum a bit (and/or Google?) or - silly thought, I know - maybe asking SSG support directly could give some further insight?
I hope you get everything working again soon though; and yeah, this game has always had some REALLY strange goings-on all over the place. Can't imagine what they were smoking when they coded it! :P



_________________
Archturus (the 'h' is silent!!) -- Rune-keeper, 105; Tailor
Deorwen -- Warden, 88+; Jeweller (+ Cook)
Gilbrindal -- Captain, 100; Historian
Kitsunegari -- Huntress, 100; Weaponsmith
Safirlotus -- Minstrel, (65+); Scholar
Skullrend -- Guardian, (52+); Jeweller
Nareraumo -- LM, (40+); Yeoman
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Sun Apr 02, 2017 12:58 pm 
User avatar

Joined: Sun Dec 19, 2010 3:46 am
Posts: 1387
Location: Malmo, Skane (the country)
Quote:
%userprofile%\AppData\Local\The Lord of the Rings Online

That one?

Been going through those log-files on occasion. Found that game was complaining about page file.
I have 32 GB RAM and page file was on auto, loads of space for it to grow, and system never used more than 1GB of it anyway.
Yet lotro seemed to keep complaining about lack of space in page file.
In the end I gave up and set it to the same as RAM. Still isn't used but atleast that made lotro shut up about it.

I get this one often too
Quote:
Attempting to set a NetSharedVisually or NetSharedPrivately property (Warsteed_Cosmetic_FX) on the client. This is not allowed, because these are server-authorative.

I can't change things about cosmetics that isn't in the game as an option. bit confused there.

This one I just find hilarious
Quote:
0x050051B8: error: The animation has 35 bones while the setup "" (0x04000058) has 41 bones. The number of bones in the animation must be the same as the setup.

So, my character has too many bones or something?


Random things.
If you feel bored one day you can change the login screen pictures. Go to installation folder \raw\en\logo and replace an image with one of same size and name (lotro_ad_pregame.jpg always shows atm so can pick that). And when you log in you can get your very own splash screen. Ofc will be overwritten from time to time.

Been trying to change that first image you get when you start the game. Atm it is Aragorn jumping into Orcs in Osgilliath. Found the image under \en and named splash_screen_en.bmp. But changing that picture didn't seem to do anything. Could be embedded nowaday ofc. There's a couple of obsolete files in the install folder, and files in more than one location.

Can also view the vids (mostly from epic) in raw\en\vignette_videos. Or the original intro movie in raw\en\introcinematic. Not many see that one these days.


Oh, and I did get it sorted. Do as normal, remove everything and start over.



_________________
Image
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Mon Apr 03, 2017 8:11 am 
User avatar

Joined: Tue Jan 18, 2011 5:36 pm
Posts: 2464
Don't ever be tempted by the bad lag and low FPS to go back to DX9 if you're on Win10. Sooner or later your whole computer, not just LOTRO, will lock up and need repairs.



_________________
Aedfrith - Yarrr! | Aldnoth - Respect mah authoritah!| Hrolfdan - Buurrp! | Rumbold - BAPPLE! | Morriarty - Yak-a-boo! | Hraldan - DORF! | Aldfryd - KYAI PAN TUO KYAI! | Aednoth - BOOM! | Rumbelina - :3 | Mishhar - Grroar!
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Wed Apr 12, 2017 6:18 pm 
User avatar

Joined: Sun Dec 19, 2010 3:46 am
Posts: 1387
Location: Malmo, Skane (the country)
Thought I'd just continue on this thread.

Yesterday I updated to latest Windows 10, the creators update. And that did not go well.
Computer randomly goes to 100% RAM usage and completely freezes. Only way to get out of it is with a hard reboot.
Started searching the interweb, and seems I'm not alone in this. First things was to disable gaming features that was added.
* Windows menu - settings - Game settings - disable Record game
* Open Xbox app - Settings - GameDVR - disable recording
And finally tried
* Windows Menu - settings - Game settings - disable Game mode
Helped a bit so I was able to get past loading screen of LOTRO, but after a short while it froze again.

Since I figured it has something to do with graphics display, I tried a complete removal of Nvidia drivers and a clean install.
That helped bit more and I could play for 20 mins or so.
Closed the game since I had other things to do. After a while computer froze on screensaver.

In the end I had to revert to a previous build of Windows (1607) and that seems to be working, for now anyway. There are nice features in Windows nowadays where you can go back to earlier build with little to zero hazzle. A good thing to have, for me at least.

As far as I've figured it, the problem is between Windows and graphics drivers.
Windows creators update can't be postponed indefinately and eventually it will be forced install. Hopefully there's new drivers from Nvidia so 3D applications won't freeze the whole computer.

Hopefully others have better luck with it than I did.



_________________
Image
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Thu Apr 13, 2017 8:53 pm 
User avatar

Joined: Thu Nov 24, 2011 2:59 pm
Posts: 1092
Location: Sweden
Install Win 7 Pro on a SSD, and boot into that. Problem solved! :mrgreen:

I will blatantly refuse Win 10 for as long as it is humanly possible. :twisted:



_________________
Archturus (the 'h' is silent!!) -- Rune-keeper, 105; Tailor
Deorwen -- Warden, 88+; Jeweller (+ Cook)
Gilbrindal -- Captain, 100; Historian
Kitsunegari -- Huntress, 100; Weaponsmith
Safirlotus -- Minstrel, (65+); Scholar
Skullrend -- Guardian, (52+); Jeweller
Nareraumo -- LM, (40+); Yeoman
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Fri Apr 14, 2017 5:04 pm 
Esquire
Esquire
User avatar

Joined: Sat Jan 14, 2017 12:41 am
Posts: 46
Location: Canada
Sorry to hear of your troubles, Obi!

A similar problem happened to me when the Nvidia 3D graphics driver things came out. I had to uninstall Nvidia, then custom re-install, but *without* the 3D drivers. It solved everything.

Good luck in getting it sorted!



_________________
Protector of Elven Values!
Saralethiel - 105 Hunter
Saradhwen - 105 Champion
Saralindele - 35 Minstrel
Offline
 Profile  
 
 Post subject: Re: Random mumble and grumble
PostPosted: Tue Jun 27, 2017 7:40 am 

Joined: Wed Jun 21, 2017 1:43 pm
Posts: 1
Aedfrith wrote:
Don't ever be tempted by the bad lag and low FPS to go back to DX9 if you're on Win10. Sooner or later your whole computer, not just LOTRO, will lock up and need repairs.


Tell me about it! What a hassle.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 8 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron